Need help to view srt Japanese subtitle in Mplayer OSX

Read the FAQ in here first then post your questions here if it doesn't help you.
Post Reply
watermen
Posts: 3
Joined: Oct 18th, '09, 14:38

Need help to view srt Japanese subtitle in Mplayer OSX

Post by watermen » Oct 18th, '09, 14:45

I am a Mac user, my current OS is Snow Leopard.

I recently found this site which provide Japanese subtitle and I was so excited, as it can help me to learn Japanese.

I downloaded the Japanese subtitles for Mr. Brain from this site and downloaded the drama from (http://www.jdramazone.com/jdramas/mr-brain-completed/)

Now my problem is, I can't see the Japanese subtitle when I use Mplayer OSX.

I have changed the srt file name to the same name as the movie mkv file. I have done everything I can, but it still can't display the Japanese srt file I download from this site.

Please help. Thanks.

Dudie
Posts: 23
Joined: Sep 4th, '06, 19:05
Location: The Netherlands

Post by Dudie » Oct 18th, '09, 16:24

I'm a mac user aswell with Leopard and I don't use Mplayer anymore. I find VLC (click here) much better.
It auto detects subs (if they are named the same and are in the same folder) and can play all kinds of formats of video, audio and subs. I advise you to throw away Mplayer and install VLC instead :D

watermen
Posts: 3
Joined: Oct 18th, '09, 14:38

Post by watermen » Oct 18th, '09, 18:56

Dudie wrote:I'm a mac user aswell with Leopard and I don't use Mplayer anymore. I find VLC (click here) much better.
It auto detects subs (if they are named the same and are in the same folder) and can play all kinds of formats of video, audio and subs. I advise you to throw away Mplayer and install VLC instead :D
I tried with VLC, it didn't work well. There are squares in the Japanese characters displayed. It is like 90% of the subtitle is displayed and the other 10% is square, and the squares are mix within the normally displayed characters. How do you solve this problem?

quanhottie
Posts: 18
Joined: Feb 24th, '09, 05:24
Location: California

Post by quanhottie » Oct 18th, '09, 20:22

I had the same exact problem but i have just Leopard and what i need was download two components for quicktime player because not even VLC could pay Blue Ray Mkv since i love to watch anime at its best quality :lol so what you have to do is download Perian (http://perian.org/) which will help play the mkv in quicktime. The other one that you need to download xiph-qt (http://www.xiph.org/quicktime/download.html) this will allow you to hear the audio because without you wouldn't hear anything. Then go to the section that says "Xiph QuickTime Components binary packages" and download the first one that says "XiphQT 0.1.9 (Mac OS X)" and its only 1.0MB. I believe that when i download and installed XiphQT I had to move it to the Library of QuickTime folder that way it can function.

Hope this helps :-)

qop123
Posts: 76
Joined: May 15th, '09, 01:57

Post by qop123 » Oct 19th, '09, 01:35

Hello~ :roll

When playing Japanese subs or Chinese subs in VLC Player, changing the text encoding from UTF-16 to UTF-8 sometimes helps.

To change the text encoding, open the sub in a text editor such as "TextWrangler", and you can change it from there. In the case of TextWrangler, the text encoding is displayed at the bottom of the window.

watermen
Posts: 3
Joined: Oct 18th, '09, 14:38

Post by watermen » Oct 19th, '09, 17:39

qop123 wrote:Hello~ :roll

When playing Japanese subs or Chinese subs in VLC Player, changing the text encoding from UTF-16 to UTF-8 sometimes helps.

To change the text encoding, open the sub in a text editor such as "TextWrangler", and you can change it from there. In the case of TextWrangler, the text encoding is displayed at the bottom of the window.
I changed it to UTF8, but those squares still persist.

voldemort
Posts: 115
Joined: Sep 6th, '09, 09:02

Post by voldemort » Oct 20th, '09, 07:14

I'm using mplayer with Linux and also had some troubles displaying the subs. But I've found some workaround which is not completely satisfying but well... so here is my method.
  • I make sure the subtitle file is in UTF-8
  • I run a Japanese terminal (I mean a terminal in japanese environment with

    Code: Select all

    export LANG=ja_JP.UTF-8
    Not sure how this is done with OSX but the weird thing is that it used to work without that trick, so maybe not needed for you)
  • I start (g)mplayer (works for both) with the following command:

    Code: Select all

     gmplayer -fontconfig -font 'Kochi Mincho' -subcp shift-jis -vf expand=:-100::2 -sub subtitles.srt video.avi
    The -vf expand option is to get the subtitle displayed below the video, you don't need it if it doesn't annoy know. The -sub option is needed only if you have a subtitles file name different from the video one (I usualy do, as I keep the same name for the english ones)
I hope this can help some of the people who are trying to display the japanese fonts.

Now I have some additionnal tricky question... How to display the Japanese subtitles AND the translated English ones a the same time for the same video ? I couldn't find so far, so I'd be really interested if one of you has a hint ;)

Drazic
Fansubber
Fansubber
Posts: 223
Joined: Aug 12th, '06, 14:28
Contact:

Post by Drazic » Oct 20th, '09, 07:24

voldemort wrote:
Now I have some additionnal tricky question... How to display the Japanese subtitles AND the translated English ones a the same time for the same video ? I couldn't find so far, so I'd be really interested if one of you has a hint ;)
You'll have to merge the subs using a subtitle editor like aegisub. afaik there's currently no player out there that can do 2 subtitle streams at the same time.

peacht
Global Moderator
Global Moderator
Posts: 865
Joined: Dec 29th, '04, 14:46
Location: UK

Post by peacht » Oct 21st, '09, 07:28

I use Movist as it has good subtitle options. It has various text encoding options which I've played around with before to view non romanised characters although I've not tried to view Japanese fonts.
It's worth a try.

voldemort
Posts: 115
Joined: Sep 6th, '09, 09:02

Post by voldemort » Oct 21st, '09, 20:33

Drazic wrote: You'll have to merge the subs using a subtitle editor like aegisub. afaik there's currently no player out there that can do 2 subtitle streams at the same time.
Yeah, not sure that would work anyway, as the timestamps would be different... and also I would like the two languages at different places on the screen (Japanese below and English at the top or something). But I'll try checking about aegisub, thanks for the hint!

golantrevize
Posts: 1
Joined: Sep 8th, '09, 23:11

Post by golantrevize » Oct 22nd, '09, 13:52

watermen wrote:I changed it to UTF8, but those squares still persist.
If you are under Snow Leopard, Quicktime X with Perian wont allow you to watch MKV files. You'll need to use Quicktime 7 (if you installed it with SL, it should be in Applications/Utilities/ or something like that). QT7 works much better than the new X version.

It should be a good alternative to VLC and may use another way to check the encoding in the subtitles. In other terms, if you try this it may work ;)

By the way, what is this site you downloaded japanese subtitles from ? I'm looking for japanese subtitles for many stuffs like Tantei Monogatari (the drama, not the movie), but I can't seem to find these kind of website anywhere!! Really frustrating !

EDIT: When you open your subtitle file with a text editor or a subtitle editor (like Jubler), do you still have those squares ??

qop123
Posts: 76
Joined: May 15th, '09, 01:57

Post by qop123 » Oct 22nd, '09, 14:32

Hello, :roll
I changed it to UTF8, but those squares still persist.
All the problems I have encountered up until now have been solved by changing the text encoding to UTF-8. I use OSX Leopard. To be sure, it might be worth a try to make a new text document in UTF-8, and copy and paste the material into it, and save the file, and change the extension to srt, and restart VLC.

If this didn't work, I don't know any other way.

How to display the Japanese subtitles AND the translated English ones a the same time for the same video ?
On Windows, you can achieve this with Media Player Classic with DirectVobSub filter.

For example, to show Japanese subs, use the built-in filter of MPC, and to show English subs, use the DirectVobSub filter, this way, two kinds of subs are displayed at the same time. And after that, you can change the position of the MPC subs from Subtitles > Options > Subtitles > Vertical.

Watching videos with two different subs makes our brain a little busy, but if we are a little more attentive, it works just fine. It is an interesting way to learn languages.
afaik there's currently no player out there that can do 2 subtitle streams at the same time.
Power DVD has this dual sub function for normal DVD disks. But it doesn't work for AVI files.

qop123
Posts: 76
Joined: May 15th, '09, 01:57

Post by qop123 » Oct 23rd, '09, 03:09

Or I might have found another solution.

There should be a font or language setting in VLC that you can change from preferences or options. And there, choose a font that is related to anything Japanese or Unicode, and you might be able to show the subs properly.

I had a similar problem playing Korean subs with DirectVobSub filter, but changing the font setting to Lucida Unicode, or changing the font to Arial with Hangul option solved the problem.

ladymenot
Posts: 35
Joined: Jan 7th, '07, 19:40
Location: Perth

Post by ladymenot » Dec 6th, '09, 05:46

qop123 wrote:Hello~ :roll

When playing Japanese subs or Chinese subs in VLC Player, changing the text encoding from UTF-16 to UTF-8 sometimes helps.

To change the text encoding, open the sub in a text editor such as "TextWrangler", and you can change it from there. In the case of TextWrangler, the text encoding is displayed at the bottom of the window.
OMG THANK YOU SO MUCH FOR THIS POST!!! I'm a mac newbie. just bought a macbook pro 1 week ago and i was frustrated cos my fave divxplayer can't seem to detect the .srt subs!! i googled it and found this post! i've changed the .srt files to UTF-8!! now i can stick to my fave divxplayer and all the subs appeared! YEYYYYYYYYYYY!! thank you so much for this post!

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest